Project

General

Profile

Bug #2426

Segfault on startup

Added by igmar 5 months ago. Updated 4 months ago.

Status:
New
Priority:
High
Assignee:
Deng Team
Category:
-
Target version:
Start date:
2020-05-23
% Done:

0%


Description

$ rpm -q doomsday
doomsday-2.2.2.3313-1.x86_64

$ gdb /usr/bin/doomsday
Using host libthread_db library "/lib64/libthread_db.so.1".
QSocketNotifier: Can only be used with threads started with QThread
[New Thread 0x7fffe3eb3700 (LWP 95597)]
[New Thread 0x7fffe36b2700 (LWP 95598)]
[New Thread 0x7fffe2eb0700 (LWP 95599)]
[New Thread 0x7fffe26af700 (LWP 95600)]
[New Thread 0x7fffe1bea700 (LWP 95601)]
[New Thread 0x7fffe13e9700 (LWP 95602)]
[New Thread 0x7fffcaabb700 (LWP 95603)]
[New Thread 0x7fffca2ba700 (LWP 95604)]
[New Thread 0x7fffc9ab9700 (LWP 95605)]
[New Thread 0x7fffc92b8700 (LWP 95606)]

Thread 1 "doomsday" received signal SIGSEGV, Segmentation fault.
0x00007ffff4fd5cf8 in _XGetRequest () from /usr/lib64/libX11.so.6

gdb) bt
#0 0x00007ffff4fd5cf8 in _XGetRequest () at /usr/lib64/libX11.so.6
#1 0x00007ffff4fc906f in XQueryExtension () at /usr/lib64/libX11.so.6
#2 0x00007ffff4fbc4a7 in XInitExtension () at /usr/lib64/libX11.so.6
#3 0x00007ffff4f856d1 in XextAddDisplay () at /usr/lib64/libXext.so.6
#4 0x00007ffff4f63a50 in XRRFindDisplay.part.0 () at /usr/lib64/libXrandr.so.2
#5 0x00007ffff4f641d8 in XRRQueryExtension () at /usr/lib64/libXrandr.so.2
#6 0x00007ffff728dceb in DisplayMode_Native_Init () at /usr/lib64/libdeng_gui.so.2.2
#7 0x00007ffff72385fc in DisplayMode_Init () at /usr/lib64/libdeng_gui.so.2.2
#8 0x000000000058efef in ClientApp::initialize() ()
#9 0x000000000055949d in main ()

History

#1 Updated by igmar 5 months ago

igmar wrote:

OS : FC32 x64

#2 Updated by thesourcehim 4 months ago

I use my own builds from git under FC32 x64 and they currently work fine.
Could you try this rpm (ignore strange build number, it's actually number of commits in git):
https://yadi.sk/d/5zSd9DAa-xX89A

#3 Updated by igmar 4 months ago

thesourcehim wrote:

I use my own builds from git under FC32 x64 and they currently work fine.
Could you try this rpm (ignore strange build number, it's actually number of commits in git):
https://yadi.sk/d/5zSd9DAa-xX89A

This one also segfaults for me. Same stacktrace.

Also available in: Atom PDF