Project

General

Profile

Feature #2379

HUD Weapon FOV 4:3 adaptation

Added by theleo_ua 2 months ago. Updated 26 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Enhancement
Target version:
Start date:
2019-12-24
% Done:

100%


Description

HUD Weapon FOV 4:3 adaptation

If HUD model is designed for 16:9 resolution, it will display with incorrect fov, when using 4:3 resolution, so if the user plays this in 16:9 with rend-model-fov 95, it will display correct fov, but when using 4:3, user will be forced to use rend-model-fov 85 or rend-model-fov 80 to make same "forward-backward axis" position of the HUD model

In other words, while 16:9 users will use rend-model-fov 95 (for 16:9-based models), 4:3 users should use rend-model-fov 85 or 80 for the same models

So:

1) I suggest to fix this, so each user (both 16:9 and 4:3) will use same rend-model-fov 95 value for each such model

2) If you need models for testing, we can discuss this in private chat (because I cannot upload such models to global public sharing for now, so only can give them to you via PM for now). For example, this issue is not reproduced with veirdo's serpent staff and wand 2.0, so you cannot (as I understand) test this issue with them, so other models are required (which I can provide via PM if needed)

NOTE: Issue was created because of this https://tracker.dengine.net/issues/2234#note-12 discussion


Related issues

Related to Bug #2234: Fov 160 + near clip plane issues with MD2 and FBX HUD ModelsClosed2017-04-03

Related to Feature #2405: Per-model FOV for rendering psprite modelsResolved2020-01-22

Associated revisions

Revision e8515281 (diff)
Added by skyjake 2 months ago

Renderer: Adjust fixed weapon FOV for 4:3 view aspect

IssueID #2379

Revision 9a6842e9 (diff)
Added by skyjake about 1 month ago

Renderer: Adjust fixed weapon FOV for 4:3 view aspect

IssueID #2379

History

#1 Updated by skyjake 2 months ago

  • Related to Bug #2234: Fov 160 + near clip plane issues with MD2 and FBX HUD Models added

#2 Updated by skyjake 2 months ago

  • Category set to Enhancement
  • Target version set to 2.3

#3 Updated by skyjake 2 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 50

I've made a possible solution for this issue. Please test with the next unstable build (3283 or later): keep the fixed FOV value at the default 95 and see how your models look in 4:3.

#4 Updated by theleo_ua about 1 month ago

tried on 2.3 Unstable [#3302] x64 and it works ok for me

#5 Updated by skyjake about 1 month ago

  • % Done changed from 50 to 100

#6 Updated by skyjake about 1 month ago

  • Target version changed from 2.3 to 2.2.2

#7 Updated by skyjake about 1 month ago

  • Status changed from In Progress to Resolved

#8 Updated by skyjake about 1 month ago

  • Related to Feature #2405: Per-model FOV for rendering psprite models added

#9 Updated by skyjake 26 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF