Project

General

Profile

Bug #237

Doom2: Courtyard, wall transparent from inside structure

Added by rekrul about 17 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
-
Target version:
-
Start date:
2005-07-01
% Done:

100%


Description

In Doom II, level 18, The Courtyard, there is a small
structure that looks normal from the outside, but from
the inside, one of the walls is transparent and part of
the floor disappears revealing the sky.

When you start the level, leave the small building,
enter the courtyard and go straight ahead to a small
set of steps. There is a small structure at the top of
the stairs and another one to the left. These will open
to release imps. The one on the left looks normal from
the outside, but when you enter it, the right wall is
completely transparent and part of the floor is missing
allowing the sky texture to show through. This is
purely a graphical glitch though, as the wall still
prevents you from walking out the side of the building.

Also, along the sides of the courtyard are structures
with pillars. When you step in the right places, hidden
doors in the back walls of these structures will open
releasing imps. In the first alcove that opens in the
structure on the left (as you enter the courtyard), you
can see a thin vertical strip of the sky texture
through the corners of the opening if you stand at the
right angle. At other angles, you get a hall of mirrors
effect where the textures meet.

For reference, I'm using v1.8.6, under Windows 98SE
with a GeForce4 MX440 video card.

Labels: Graphics

History

#1 Updated by rekrul about 17 years ago

#2 Updated by dark_pulse about 17 years ago

Logged In: YES
user_id=649259

This is more likely GLBSP messing up, rather than an actual
engine bug.

#3 Updated by danij almost 17 years ago

Logged In: YES
user_id=849456

This is actually two seperate errors, both of which are not
bugs in Doomsday.

The first glitch is indeed caused by bad glnodes. If you
create the nodes in a more recent version of glBSP (eg
ver2.20) this glitch is fixed.

The second one is an error in Doom2.WAD which would either
need some special logic to detect it or a kludge to fix this
isolated incidence.

#4 Updated by danij over 15 years ago

Logged In: YES
user_id=849456
Originator: NO

Now that maploader.dll has been updated to glBSP 2.20 these problems have been resolved due to fixing these for us. Closing.

Also available in: Atom PDF