Project

General

Profile

Bug #2366

"texreset" breaks halo textures

Added by skyjake 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Regression
Target version:
Start date:
2019-12-10
% Done:

100%


Description

The "texreset" command breaks halo textures and causes GL errors (presumably due to use invalid GL texture IDs).

The full "reset" command behaves correctly.


Related issues

Related to Bug #2365: Halos from Light decorations not visibleClosed2019-12-10

Associated revisions

Revision 143e236a (diff)
Added by skyjake 7 months ago

Fixed|Renderer: "texreset" breaks decoration halos

IssueID #2366

Revision f10c8e5d (diff)
Added by skyjake 7 months ago

Fixed|Renderer: "texreset" breaks decoration halos

IssueID #2366

History

#1 Updated by skyjake 7 months ago

  • Related to Bug #2365: Halos from Light decorations not visible added

#2 Updated by skyjake 7 months ago

Looks like the obsolete texture IDs are cached somewhere and then used for drawing halos after the texreset.

#3 Updated by skyjake 7 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

#4 Updated by skyjake 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF