Project

General

Profile

Bug #2365

Halos from Light decorations not visible

Added by skyjake 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Regression
Target version:
Start date:
2019-12-10
% Done:

100%


Description

Halos from any of the defined Light decorations are not visible. This includes the built-in ones from libdoom.pk3.

It appears Lumobjs are not being generated for the decorations, and therefore they don't get halos either.


Related issues

Related to Bug #2366: "texreset" breaks halo texturesClosed2019-12-10

Associated revisions

Revision 8aea6048 (diff)
Added by skyjake 4 months ago

Fixed|Renderer: Light decorations are not visible

IssueID #2365

Revision 66191dde (diff)
Added by skyjake 4 months ago

Fixed|Renderer: Light decorations are not visible

IssueID #2365

History

#1 Updated by skyjake 4 months ago

  • Description updated (diff)

#2 Updated by skyjake 4 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

The problem was that surfaces with decorated materials weren't correctly registered in their subsectors, so they were never decorated with lumobjs.

#3 Updated by skyjake 4 months ago

  • Related to Bug #2366: "texreset" breaks halo textures added

#4 Updated by skyjake 4 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF