Project

General

Profile

Bug #2357

[Hexen] Warping while player is dead leads to inoperable player weapon

Added by skyjake about 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Regression
Target version:
Start date:
2019-11-30
% Done:

100%


Description

At least in Hexen:
  1. Die in combat.
  2. Warp to another map using the console.
  3. The player weapon is immediately lowered and cannot be brought up.

Associated revisions

Revision 92f3df8f (diff)
Added by skyjake about 2 months ago

Fixed|Hexen: Workaround for warping while dead

IssueID #2357

Revision 5f4b16c0 (diff)
Added by skyjake about 2 months ago

Fixed|Hexen: Workaround for warping while dead

IssueID #2357

History

#1 Updated by skyjake about 2 months ago

  • Category changed from Defect to Regression
  • Status changed from New to Resolved
  • % Done changed from 0 to 100

The problem was that after warping, player state would be restored to what it was before the warp (zero health).

This is likely a bug in GameSession management when it comes to hubs and player state. Normally inside hubs, player state should be restored between warps, but warping as a dead player is special case that should lead to a normal reborn event. The player does get respawned as alive, but then the zero health is restored afterwards.

#2 Updated by skyjake about 2 months ago

  • Subject changed from Warping while player is dead leads to inoperable player weapon to [Hexen] Warping while player is dead leads to inoperable player weapon

#3 Updated by skyjake about 1 month ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF