Project

General

Profile

Bug #2328

Not all official releases of IWADs are recognized (e.g., older than v1.9)

Added by Zarky over 1 year ago. Updated 10 months ago.

Status:
New
Priority:
Low
Assignee:
Category:
User experience
Target version:
Start date:
2019-04-25
% Done:

0%


Description

Some official releases are not listed in the doomsday engine menu, which the hashs can be found here:
https://github.com/libretro/libretro-database/blob/master/dat/DOOM.dat


Related issues

Related to Bug #2382: Recognizing IWAD/PWAD files with more accuracy (using CRC-32)New2019-12-27

Associated revisions

Revision 73f5319c (diff)
Added by skyjake 10 months ago

Resources|libdoomsday: Detect DOOM2.WAD v1.7a

The detected package is numbered 1.7.1 since only numbers are allowed.

IssueID #2328

Revision 62059552 (diff)
Added by skyjake 10 months ago

Resources|libdoomsday: Detecting DOOM2.WAD v1.7 and v1.7a

The versions 1.7 and 1.7a are similar enough to not require separate entries.

The detected package is numbered 1.7 in either case.

IssueID #2328

History

#1 Updated by skyjake over 1 year ago

This looks like a nice resource, thank you.

However, it should be noted that even if Doomsday recognizes all these versions, they may not work exactly right because the code expects the latest (e.g., Doom 1.9) WADs.

#2 Updated by skyjake 11 months ago

  • Target version changed from 2.2 (2019) to 2.2.x

#3 Updated by skyjake 11 months ago

  • Subject changed from Some official releases are not listed in the doomsday engine to Not all official releases of IWADs are recognized (e.g., older than v1.9)

#4 Updated by skyjake 11 months ago

  • Target version changed from 2.2.x to 2.3

#5 Updated by skyjake 10 months ago

  • Description updated (diff)

#6 Updated by skyjake 10 months ago

  • Related to Bug #2382: Recognizing IWAD/PWAD files with more accuracy (using CRC-32) added

Also available in: Atom PDF