Project

General

Profile

Bug #2254

[Render hack] TNT map02: Deep Water not supported

Added by sonicdoommario over 2 years ago. Updated 4 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Regression
Target version:
Start date:
2017-07-01
% Done:

100%

Tags:

Description

I was playing through Map02 of TNT the other day and noticed the deep-water pool in the room with the Blue and Yellow keys was not being rendering properly. Although the deep-water/invisible bridge hacks are supported as of Doomsday 1.12, this one may not appear to be (can't confirm if this displayed properly in 1.12, however). Attached is a screenshot.

tnt02water.png (1.72 MB) tnt02water.png sonicdoommario, 2017-07-01 02:16

Related issues

Related to Bug #745: [Render hack] Deep water tricks not supportedClosed2009-08-08

Related to Feature #1603: Support for id Tech 1 map hacksProgressed2003-07-17

Associated revisions

Revision ca6a4098 (diff)
Added by skyjake 4 months ago

Fixed: Deep water in TNT map 02

Link visplanes based on the analysis done by the id Tech 1 map importer.

IssueID #2254

History

#1 Updated by skyjake over 2 years ago

  • Tags set to MapData, Renderer
  • Category set to Regression
  • Assignee set to skyjake
  • Target version set to Rendering

This is a regression... I remember working on this very issue back in the day, but since then the map data has undergone a number of changes so it has likely broken down relatively recently.

#2 Updated by skyjake over 2 years ago

  • Priority changed from Normal to High

#3 Updated by skyjake 4 months ago

  • Related to Bug #745: [Render hack] Deep water tricks not supported added

#4 Updated by skyjake 4 months ago

  • Target version changed from Rendering to 2.2.x

#5 Updated by skyjake 4 months ago

  • Related to Feature #1603: Support for id Tech 1 map hacks added

#6 Updated by skyjake 4 months ago

  • Subject changed from Variant of Deep Water rendering hack not supported? to Variant of Deep Water rendering hack not supported
  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Fixed with a new approach.

#7 Updated by skyjake 4 months ago

  • Target version changed from 2.2.x to 2.3

#8 Updated by skyjake 4 months ago

  • Subject changed from Variant of Deep Water rendering hack not supported to TNT map02: Deep Water rendering hack not supported

#9 Updated by skyjake 4 months ago

  • Subject changed from TNT map02: Deep Water rendering hack not supported to [Render hack] TNT map02: Deep Water not supported

Also available in: Atom PDF