Project

General

Profile

Bug #225

SuSE missing dependencies (libvorbis)

Added by alinezhad over 17 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
-
Target version:
Start date:
2005-03-19
% Done:

100%


Description

I've downloaded the 1.8.6 and tried to install it on my
SuSE 9.1 box. "./configure" step is passed correctly;
But, I recieve errors at the "make" step, last lines of
which are here:

===============================
ranlib .libs/libdssdlmixer.a
creating libdssdlmixer.la
/usr/bin/sed: can't read /usr/lib/libvorbisfile.la: No
such file or directory
libtool: link: `/usr/lib/libvorbisfile.la' is not a
valid libtool archive
make3: * [libdssdlmixer.la] Error 1
make3: Leaving directory
`/home/s4/deng-1.8.6/Src/dsSDLMixer'
make2:
[all-recursive] Error 1
make2: Leaving directory `/home/s4/deng-1.8.6/Src'
make1:
[all-recursive] Error 1
make1: Leaving directory `/home/s4/deng-1.8.6'
make: *
[all] Error 2 ===============================

Can you help me solve this? I couldn't find the right
solution by a lot of attempt.

Thank you for your notice,
Bahram Alinezhad,
Rudehen, Tehran, Iran.

History

#1 Updated by alinezhad over 17 years ago

Logged In: YES
user_id=1241178

?!

#2 Updated by skyjake over 17 years ago

Logged In: YES
user_id=717323

Building Doomsday requires the development libraries and headers for
SDL_mixer. These have libvorbis as a dependency. Apparently you don't
have the development libraries of SDL_mixer installed?

I have two suggestions:

1. Install the libvorbis-devel package. SuSE appears to have this package
available.

2. Install the SDL_mixer development libraries. Check the www.libsdl.org
website for both SDL and SDL_mixer development packages.

PS: I have received your two emails about this issue, and I did reply to
both of them immediately after receiving them. Evidently the replies didn't
make it through. In the future, I recommend using the forums or the deng
SourceForge pages to reach me.

#3 Updated by alinezhad about 17 years ago

Logged In: YES
user_id=1241178

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
"Jaakko Kernen" ()
wrote:
---------

[...]
1. Install the libvorbis-devel package. SuSE appears to have
this package available.

2. Install the SDL_mixer development libraries. Check the
www.libsdl.org website for both SDL and SDL_mixer
development packages.
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<-

The problem solved by installing libvorbis-devel only.
SuSE (at least 9.x) does not need SDL_mixer-devel; The only
development file (i.e. /usr/include/SDL/SDL_mixer.h) is
within SDL_mixer package.

Perhaps, in the next versions of doomsday, you should fix
the problem of two pre-requisites which should be checked at
"configure" step to avoid errors at "make" step:
1-libpng-devel 2-libvorbis-devel.

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
PS: I have received your two emails about this issue, and I
did reply to both of them immediately after receiving them.
Evidently the replies didn't make it through. In the future,
I recommend using the forums or the deng SourceForge pages
to reach me.
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

I wonder: You had replied me but I didn't receive anything!

Again, Thank you very much for your valuable software.

I have a suggestion and am going to bring it forward at:

http://sourceforge.net/tracker/?group_id=74815&atid=542102

Take a look at it.

Thank you for your notice,
Bahram Alinezhad,
Registered linux user #375283 (counter.li.org)
Rudehen, Tehran, Iran.

#4 Updated by alinezhad about 17 years ago

Logged In: YES
user_id=1241178

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
"Jaakko Kernen" ()
wrote:
---------

[...]
1. Install the libvorbis-devel package. SuSE appears to have
this package available.

2. Install the SDL_mixer development libraries. Check the
www.libsdl.org website for both SDL and SDL_mixer
development packages.
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<-

The problem solved by installing libvorbis-devel only.
SuSE (at least 9.x) does not need SDL_mixer-devel; The only
development file (i.e. /usr/include/SDL/SDL_mixer.h) is
within SDL_mixer package.

Perhaps, in the next versions of doomsday, you should fix
the problem of two pre-requisites which should be checked at
"configure" step to avoid errors at "make" step:
1-libpng-devel 2-libvorbis-devel.

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
PS: I have received your two emails about this issue, and I
did reply to both of them immediately after receiving them.
Evidently the replies didn't make it through. In the future,
I recommend using the forums or the deng SourceForge pages
to reach me.
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

I wonder: You had replied me but I didn't receive anything!

Again, Thank you very much for your valuable software.

I have a suggestion and am going to bring it forward at:

http://sourceforge.net/tracker/?group_id=74815&atid=542102

Take a look at it.

Thank you for your notice,
Bahram Alinezhad,
Registered linux user #375283 (counter.li.org)
Rudehen, Tehran, Iran.

#5 Updated by yagisan about 16 years ago

Logged In: YES
user_id=1248824

This is a bug with the suse SDL_Mixer headers. I can't
repoduce it on other distros (ie Ubuntu Dapper in a fresh
pbuilder setup) with current release (1.9.0beta4). Closing
bug. Please re-open if you can reproduce it.

Also available in: Atom PDF