Project

General

Profile

Feature #2247

Upgrade to new FMOD Low Level Programmer API

Added by skyjake about 5 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
3rd party compatibility
Target version:
Start date:
2017-05-01
% Done:

100%

Tags:

Description

FMOD Ex is no longer in development. It has been replaced with the new FMOD Studio low-level programmer API, which lacks some features of FMOD Ex but is also more flexible in other ways. Since it looks like the FMOD Ex SDK is no longer available, the FMOD audio plugin should be updated to use the latest APIs.

Associated revisions

Revision a75939d3 (diff)
Added by skyjake about 5 years ago

Audio|FMOD: Updated FMOD plugin to use FMOD Studio low-level API

IssueID #2247

Revision cc89d6a9 (diff)
Added by skyjake over 3 years ago

Audio: Selecting the FMOD output driver

The low-level API allows selecting which of the available audio outputs is used. The output also implicitly determines which speaker mode setting is used.

IssueID #2247

History

#1 Updated by skyjake about 5 years ago

  • Description updated (diff)

#2 Updated by skyjake about 5 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 70

Output driver selection and speaker mode options are still missing.

#3 Updated by skyjake over 3 years ago

  • % Done changed from 70 to 80

#4 Updated by skyjake over 3 years ago

  • Status changed from In Progress to Progressed

#5 Updated by skyjake over 3 years ago

  • Status changed from Progressed to Resolved
  • % Done changed from 80 to 100

#6 Updated by skyjake over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF