Project

General

Profile

Feature #2238

Configure game rules in custom profiles

Added by skyjake about 5 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
Enhancement
Target version:
Start date:
2017-04-04
% Done:

100%


Description

In addition to start map and skill, default game rules could be configured in a custom profile so it is not necessary to use command-line options such as:
  • -fast
  • -turbo
  • -respawn

Related issues

Related to Feature #1604: Game rules (1p and MP)New

Related to Feature #1516: [Heretic|Hexen] Add Doom-like option for fast monstersNew2010-04-13

Related to Feature #2241: Configure games via Home UI (advanced users, cf. autoexec.cfg)Progressed2017-04-05

History

#1 Updated by skyjake about 5 years ago

#2 Updated by skyjake over 3 years ago

  • Related to Feature #1516: [Heretic|Hexen] Add Doom-like option for fast monsters added

#3 Updated by skyjake over 3 years ago

  • Related to Feature #2241: Configure games via Home UI (advanced users, cf. autoexec.cfg) added

#4 Updated by skyjake over 3 years ago

  • Related to deleted (Feature #2241: Configure games via Home UI (advanced users, cf. autoexec.cfg))

#5 Updated by skyjake over 3 years ago

  • Is duplicate of Feature #2241: Configure games via Home UI (advanced users, cf. autoexec.cfg) added

#6 Updated by skyjake over 3 years ago

  • Status changed from New to Closed

Merged with #2241.

#7 Updated by skyjake over 3 years ago

  • Target version deleted (2.1 (Late 2018))

#8 Updated by skyjake over 3 years ago

  • Status changed from Closed to In Progress
  • Assignee set to skyjake
  • Target version set to 2.1 (Late 2018)

#9 Updated by skyjake over 3 years ago

  • Is duplicate of deleted (Feature #2241: Configure games via Home UI (advanced users, cf. autoexec.cfg))

#10 Updated by skyjake over 3 years ago

  • Related to Feature #2241: Configure games via Home UI (advanced users, cf. autoexec.cfg) added

#11 Updated by skyjake over 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Games can now define gameplay options whose values can be set per-profile in the game library.

This currently supports boolean toggles and numbers within a range.

#12 Updated by skyjake over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF