Project

General

Profile

Bug #2234

Fov 160 + near clip plane issues with MD2 and FBX HUD Models

Added by theleo_ua over 3 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Defect
Target version:
Start date:
2017-04-03
% Done:

100%


Description

Fov 160 + near clip plane issues with MD2 and FBX HUD Models

1) Set fov to 160
2) Try to modify offsets in veirdo's 2.0 pack http://dengine.net/talk/discussion/1887/redirect/p1#topic for wand HUD model, for example from <0, -8, -9> to <0, -8, -2>

Actual result:
http://storage8.static.itmages.ru/i/17/0403/h_1491208720_4077210_b84d58a306.png
http://storage8.static.itmages.ru/i/17/0403/h_1491208720_2770528_2f6cbfe4d9.png
http://storage9.static.itmages.ru/i/17/0403/h_1491208721_1011750_e26aaa3c5f.png
Expected result: https://dl.dropboxusercontent.com/u/25137016/modelFormat/HUD_Wand_01.png

For workaround you can change Yoffset <0, -12, -6> but it brokes model perspective

NOTE: same issue is reproduced for old MD2 models (workaround for MD2 is increasing X and Z scale (without changing Y scale), so in this case changing Yoffset will not cut the model. This workaround doesn't work for FBX due to lack of scale option in DEI definitions, and also taking into account more complicated animations for FBX models, which will look like weird with changed scale)

Reproduced in 2.0 Stable [#2281] x64 (Windows)


Related issues

Related to Feature #2358: Fixed FOV for rendering weapon modelsClosed2019-12-01

Related to Feature #2379: HUD Weapon FOV 4:3 adaptationClosed2019-12-24

History

#1 Updated by skyjake over 3 years ago

  • Target version set to 2.0.1

#2 Updated by skyjake over 3 years ago

  • Target version changed from 2.0.1 to 2.0.2

#3 Updated by skyjake over 3 years ago

  • Target version changed from 2.0.2 to 2.0.3

#4 Updated by skyjake over 3 years ago

  • Target version changed from 2.0.3 to 72

#5 Updated by skyjake about 2 years ago

  • Target version changed from 72 to Rendering

#6 Updated by skyjake 11 months ago

  • Category set to Defect

This should be solved by #2358.

#7 Updated by skyjake 11 months ago

  • Related to Feature #2358: Fixed FOV for rendering weapon models added

#8 Updated by skyjake 11 months ago

  • Status changed from New to Feedback
  • Assignee changed from skyjake to theleo_ua

#9 Updated by theleo_ua 11 months ago

Hi skyjake

you changed status to feedback and assignee to me - this mean something is required from my side? If yes - what exactly is required from my side?

#10 Updated by skyjake 11 months ago

Mainly to verify whether the fixed FOV angle for weapons in version 2.2 resolves this issue, so it can be closed.

#11 Updated by theleo_ua 11 months ago

skyjake wrote:

Mainly to verify whether the fixed FOV angle for weapons in version 2.2 resolves this issue, so it can be closed.

thanks, will do this when have time

#12 Updated by theleo_ua 10 months ago

  • Assignee changed from theleo_ua to skyjake

skyjake wrote:

Mainly to verify whether the fixed FOV angle for weapons in version 2.2 resolves this issue, so it can be closed.

Hi again

I checked this issue in Doomsday 2.2 (build 3272) and it works as expected. But - there is one problem: if Hud model is designed for 16:9 resolution, it will display with incorrect fov, when using 4:3 resolution, so if the user plays this in 16:9 with rend-model-fov 95, it will display correct fov, but when using 4:3, user will be forced to use rend-model-fov 85 or rend-model-fov 80 to make same "forward-backward axis" position of the HUD model

In other words, while 16:9 users will use rend-model-fov 95 (for 16:9-based models), 4:3 users should use rend-model-fov 85 or 80 for the same models

So:

1) I suggest to fix this, so each user (both 16:9 and 4:3) will use same rend-model-fov 95 value for each such model

2) If you need models for testing, we can discuss this in private chat (because I cannot upload such models to global public sharing for now, so only can give them to you via PM for now). For example, this issue is not reproduced with veirdo's serpent staff and wand 2.0, so you cannot (as I understand) test this issue with them, so other models are required (which I can provide via PM if needed)

3) Should seperate issue be created for this?

#13 Updated by skyjake 10 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

All right, closing this issue since the view FOV is now independent and also weapon models have a smaller near plane clip distance.

Please submit a new Feature issue for the weapon FOV 4:3 adaptation.

#14 Updated by skyjake 10 months ago

Also available in: Atom PDF