Project

General

Profile

Bug #2216

qt locale setting

Added by g_man over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Defect
Start date:
2017-03-16
% Done:

100%

Tags:

Description

Linux os (manjaro). I have to start doomsday with ENV=LANG C, otherwise I get the same error as in #1021. It seems that my locale (it_IT.UTF-8) is not being overriden by qt, which leads to incorrect decimal point formatting in configuration file.


Related issues

Related to Bug #1021: Number and time formatting depends from localeClosed2012-04-11

Associated revisions

Revision 7bb85733 (diff)
Added by skyjake over 5 years ago

Unix|libcore: Set preferred locale for number formatting earlier

Also, specifically request "C" for number formatting.

IssueID #2216

Revision 60ad1883 (diff)
Added by skyjake over 5 years ago

Unix|libcore: Set preferred locale for number formatting earlier

Also, specifically request "C" for number formatting.

IssueID #2216

History

#1 Updated by skyjake over 5 years ago

  • Category set to Defect
  • Assignee set to skyjake
  • Target version set to 2.0 – Home UI & Packages

I'll check that it overrides the locale for number formatting.

#2 Updated by skyjake over 5 years ago

  • Tags set to Linux
  • Status changed from New to In Progress

#3 Updated by skyjake over 5 years ago

The locale that Doomsday attempts to use is "en_US.UTF8". Do you have that one available? (check locale -a) If not, that might be what's causing the issue.

#4 Updated by skyjake over 5 years ago

  • Description updated (diff)

#5 Updated by skyjake over 5 years ago

  • Related to Bug #1021: Number and time formatting depends from locale added

#6 Updated by skyjake over 5 years ago

Please check if the changes in 7bb85733b14 have any effect on the issue.

#7 Updated by g_man over 5 years ago

The issue is fixed with 7bb85733b14, thanks.

#8 Updated by skyjake over 5 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

No problem. :)

Also available in: Atom PDF