Project

General

Profile

Bug #2211

Cleric flechette trick causes a hang (related to mobj damage particle effects)

Added by theleo_ua over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Defect
Start date:
2017-03-12
% Done:

100%

Tags:

Description

Cleric flechette trick hangs doomsday

1) Start game as cleric and type indiana cheat
2) Try to use flechette and then disc of repulsion, as in this video: https://www.youtube.com/watch?v=4SfEVjK0-DQ

Actual result: doomsday hangs
Expected result: no any hang. Poison cloud is pushed as in this video: https://www.youtube.com/watch?v=4SfEVjK0-DQ

Reproduced in 2.0 RC2 build 2257, and also in 1.15.8

CLERIC_FLECHETTE_TESTMOD.pk3 (31.2 KB) CLERIC_FLECHETTE_TESTMOD.pk3 theleo_ua, 2017-03-16 23:09
doomsday.out (57.8 KB) doomsday.out theleo_ua, 2017-03-16 23:17

Related issues

Related to Bug #911: [Hexen] Poison cloud vs Repulsion DiscClosed2010-05-30

Associated revisions

Revision a17d7526 (diff)
Added by skyjake over 5 years ago

Fixed|World|Particles: Set a maximum limit for particles spawned by damage

IssueID #2211

Revision df437980 (diff)
Added by skyjake over 5 years ago

Fixed|World|Particles: Set a maximum limit for particles spawned by damage

IssueID #2211

History

#1 Updated by skyjake over 5 years ago

  • Related to Bug #911: [Hexen] Poison cloud vs Repulsion Disc added

#2 Updated by skyjake over 5 years ago

  • Tags set to Gameplay, Hexen
  • Subject changed from Cleric flechette trick hangs doomsday to Cleric flechette trick causes a hang
  • Category set to Defect
  • Target version set to 2.0 – Home UI & Packages

#3 Updated by skyjake over 5 years ago

  • Assignee changed from Deng Team to skyjake

#4 Updated by skyjake over 5 years ago

This works fine for me on the 64-bit macOS build 2257.

You are using Windows? Do you have the 32 or 64-bit version of Doomsday?

#5 Updated by theleo_ua over 5 years ago

Windows 7 x64
x64 version of doomsday 2.0 and x32 version of doomsday 1.15.8 (reproduced on both)

Should I upload cfg/logs/video of this issue?

#6 Updated by skyjake over 5 years ago

theleo_ua wrote:

Should I upload cfg/logs/video of this issue?

The doomsday.out might help.

I tried in Windows 10 x64, using the 64-bit build 2257 and I couldn't get it to hang. Perhaps a video might show if you're doing it in some particular way / place that is affecting the issue? Are you able to reproduce the problem anywhere?

#7 Updated by theleo_ua over 5 years ago

I'm assured that issue was reproducible without addons, but maybe some resourse cache or other things made this, so now I cannot reproduce this without addons.

But I found the source of the issue: if hexen monsters have blood particles with "damage mobj" indentifier, then cleric flechette trick will cause a hang. I attached example of such mod (just add it with package manager and try cleric flechette trick for example with ettins on map01) and doomsday.out (if needed). Please note, that to reproduce this issue, several tries may be needed

Also I found workaround for this: avoid any "damage mobj" particles, and change "damage mobj" for example to "State = ettin_pain1", so this way cleric flechette trick will not cause a hang

So if you are not interested to investigate, why "damage mobj" causes a hang with cleric flechette trick, please close this issue

Sorry for the inconvenience!

#8 Updated by skyjake over 5 years ago

  • Subject changed from Cleric flechette trick causes a hang to Cleric flechette trick causes a hang (related to mobj damage particle effects)

#9 Updated by skyjake over 5 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Thanks for the easy-to-use mod to trigger the bug. :) The problem was that the number of particles spawned from damage was uncapped, which meant that when a large number of damage was being dealt, it was trying to create an extremely large number of particles... Fixed for the next build.

#10 Updated by skyjake over 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF