Project

General

Profile

Feature #2177

Savegames are not completely separated between profiles

Added by Drako almost 6 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Redesign
Target version:
Start date:
2016-09-04
% Done:

100%

Tags:

Description

build 2072
Savegames are not completely separated between profiles. I played Doom2 in the profile automatically created. I made several savegames. These saves were visible in the home UI and inside the game. Then I crated a new profile and chose Doom2 game. In the UI for that profile no savegames were visible but inside the game (through Load Game menu) all the savegames from the automatically created profile were accessible. It seems that it should not be the case.


Related issues

Related to Feature #1976: Replace old Save/Load menu with new UI widgetsNew2015-02-12

Related to Feature #1732: Libcommon savegame systemClosed2007-03-20

Related to Feature #1203: Additional save slots — revised save managementProgressed2003-06-20

Related to Feature #1774: Use "-savedir" option to the configure where saves are storedNew2014-04-20

Is duplicate of Feature #1446: Separate saved games for game profiles and usersClosed2007-05-20

Associated revisions

Revision 5143d824 (diff)
Added by skyjake over 3 years ago

SaveGame|UI: Custom profiles have their own save folders

Each custom profile is assigned a unique empty save folder when the profile is created.

SaveGames can be queried for the current game profile’s save path.

IssueID #2177

Revision 5b2ad745 (diff)
Added by skyjake over 3 years ago

UI|SaveGames: Creating a custom save folder

Older custom profiles naturally don’t yet have a custom save folder, so offer to create one in the context menu.

Also improved some UI strings.

IssueID #2177

History

#1 Updated by skyjake almost 6 years ago

  • Tracker changed from Bug to Feature
  • Subject changed from Savegames are not completely separated between profiles. to Savegames are not completely separated between profiles
  • Category changed from Defect to Redesign

I'm converting this to a Feature because the management of savegames is working as intended at the moment. The old "slot" mechanism is inherited from the original games, which made no effort to segregate savegames in relation to WAD usage.

What is needed here is to replace the old slot mechanism with a savegame collection that supports an unlimited number of save files and works the same across all games and profiles. That way the UI can only show the relevant save files for each game/profile.

#2 Updated by skyjake almost 6 years ago

  • Related to Feature #1976: Replace old Save/Load menu with new UI widgets added

#3 Updated by skyjake almost 6 years ago

  • Is duplicate of Feature #1446: Separate saved games for game profiles and users added

#4 Updated by skyjake almost 6 years ago

  • Status changed from New to Closed

#5 Updated by skyjake almost 6 years ago

#6 Updated by skyjake almost 6 years ago

  • Related to Feature #1203: Additional save slots — revised save management added

#7 Updated by skyjake almost 6 years ago

  • Status changed from Closed to New

#8 Updated by skyjake about 5 years ago

  • Priority changed from Normal to High
  • Target version set to Rendering

#9 Updated by skyjake about 5 years ago

  • Related to Feature #1774: Use "-savedir" option to the configure where saves are stored added

#10 Updated by skyjake over 3 years ago

  • Status changed from New to In Progress
  • Assignee set to skyjake
  • Target version changed from Rendering to 2.1 (Late 2018)

This should be addressed before the 2.1 release. Basically, every profile needs to have a unique save folder.

The built-in profiles already do have separate folders because they have different game modes, but custom profiles needs to be assigned new folders.

#11 Updated by skyjake over 3 years ago

  • % Done changed from 0 to 70

#12 Updated by skyjake over 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 70 to 100

#13 Updated by skyjake over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF