Project

General

Profile

Feature #2168

Feature #1601: Package management

Package compatibility check in multiplayer games

Added by skyjake almost 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Enhancement
Start date:
2016-07-22
% Done:

100%


Description

The client must use add-ons that are compatible with the ones used by the server. However, the client should be allowed to use add-ons that make visual/audio-only alterations, since the server never needs to load such add-ons.

Some new logic may need to be introduced to determine if a package contains gameplay-altering DED definitions (such as new states or things).

The information in local server broadcasts and master server announcements must support listing the required packages. This can be achieved e.g. with JSON as the data format.


Related issues

Related to Feature #1753: Improved Master Server APIRejected2014-04-18

History

#1 Updated by skyjake almost 6 years ago

  • Description updated (diff)

#2 Updated by skyjake almost 6 years ago

  • Description updated (diff)

#3 Updated by skyjake almost 6 years ago

  • Priority changed from Normal to High

#4 Updated by skyjake over 5 years ago

#5 Updated by skyjake over 5 years ago

  • Tags changed from Multiplayer, Definitions, MapData, Resources, Server, Client, Packages to Multiplayer, Definitions, MapData, Resources, Server, Client, Packages, MasterServer
  • Description updated (diff)
  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

#6 Updated by skyjake over 5 years ago

  • % Done changed from 100 to 90

A notification dialog should still be shown if there are potential version conflicts.

#7 Updated by skyjake over 5 years ago

  • % Done changed from 90 to 100

#8 Updated by skyjake over 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF