Project

General

Profile

Feature #2142

Color adjustment should only apply to game view

Added by vermil over 4 years ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
User experience
Target version:
Start date:
2015-12-10
% Done:

100%


Description

Dday's brightness options affect the entire screen, even when windowed.

This can make it difficult to multitask while Dday is open.


Related issues

Related to Feature #2123: Option Needed to tailor the anaglyph effect for TriOviz Inficolor Glasses...New2015-11-04

Related to Bug #2411: Monitor color adjustment via platform-specific APIs is unreliable (e.g., Windows 10)Resolved2020-02-01

History

#1 Updated by skyjake over 4 years ago

  • Tags set to DisplayMode
  • Tracker changed from Bug to Feature
  • Category set to User experience

We are currently applying color adjustments using the system APIs, which work on the entire display and typically can't be confined to a window. Therefore, this is working as intended and I'm making this a feature request.

The solution would be to apply the color adjustments manually using a shader in one of the post-processing Lens FX passes. (This would also be useful in the related linked issue.)

#2 Updated by skyjake over 4 years ago

  • Subject changed from Brightness options affect entire screen to Color adjustment should only apply to Doomsday window or game view

#3 Updated by skyjake over 4 years ago

  • Related to Feature #2123: Option Needed to tailor the anaglyph effect for TriOviz Inficolor Glasses... added

#4 Updated by skyjake 4 months ago

  • Priority changed from Normal to Low
  • Target version set to Rendering

#5 Updated by skyjake about 2 months ago

  • Related to Bug #2411: Monitor color adjustment via platform-specific APIs is unreliable (e.g., Windows 10) added

#6 Updated by skyjake about 2 months ago

  • Status changed from New to Resolved
  • Assignee set to skyjake
  • Target version changed from Rendering to 2.3
  • % Done changed from 0 to 100

The color adjustments are now done via a shader, and only apply to the game view.

#7 Updated by skyjake about 2 months ago

  • Subject changed from Color adjustment should only apply to Doomsday window or game view to Color adjustment should only apply to game view

Also available in: Atom PDF