Project

General

Profile

Bug #2141

Use server IDs to detect which public/private entries belong to the same server in the Multiplayer list

Added by skyjake over 6 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Defect
Target version:
Start date:
2015-12-09
% Done:

100%


Description

One instance of the server is located via broadcast on the local network, while the other instance is received from the master server.

Servers should have randomized unique IDs (cf. client IDs) to detect when server announcements from various sources refer to the same server.


Related issues

Related to Feature #1753: Improved Master Server APIRejected2014-04-18

Related to Bug #2285: Extreme lag with LAN discovery of multiple (12) local serversClosed2018-10-03

Is duplicate of Bug #1882: 1.15.0 Build #1385 Multiplayer options game server listClosed2014-10-18

Associated revisions

Revision 6556afa1 (diff)
Added by skyjake over 3 years ago

Server|Network|API|Web: Added server instance IDs

A random ID number is given to each running server so clients can detect duplicate servers.

IssueID #2141

Revision 231c030a (diff)
Added by skyjake over 3 years ago

UI|Home|Multiplayer: Use server IDs to detect duplicates

The UI prefers to show the LAN version of the server.

IssueID #2141

History

#1 Updated by skyjake over 6 years ago

#2 Updated by skyjake over 6 years ago

  • Target version changed from 50 to 2.1 (Late 2018)

#3 Updated by skyjake over 6 years ago

  • Priority changed from High to Normal

#4 Updated by skyjake almost 6 years ago

  • Is duplicate of Bug #1882: 1.15.0 Build #1385 Multiplayer options game server list added

#5 Updated by skyjake almost 6 years ago

  • Status changed from New to Closed

This has been handled as part of #2196.

#6 Updated by skyjake over 5 years ago

  • Assignee set to skyjake
  • Target version changed from 2.1 (Late 2018) to 2.0 – Home UI & Packages
  • % Done changed from 0 to 100

The Multiplayer list in Home shows all local servers plus the servers from the master, however the local ones are labeled "LAN". The server IP addresses are shown in the server details popup (public IP for servers from the master, local IP for LAN servers).

#7 Updated by skyjake over 5 years ago

  • Tags changed from Multiplayer, RingZero, Server, UI to Multiplayer, Server, UI, Home
  • Subject changed from Home screen shows duplicate entries for servers on local network to Use server IDs to detect which public/private entries belong to the same server in the Multiplayer list
  • Status changed from Closed to New
  • Target version changed from 2.0 – Home UI & Packages to 2.1 (Late 2018)
  • % Done changed from 100 to 30

#8 Updated by skyjake over 5 years ago

  • Status changed from New to Progressed

#9 Updated by skyjake over 3 years ago

  • Related to Bug #2285: Extreme lag with LAN discovery of multiple (12) local servers added

#10 Updated by skyjake over 3 years ago

  • Status changed from Progressed to Resolved
  • % Done changed from 30 to 100

#11 Updated by skyjake over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF