Project

General

Profile

Bug #208

Shiny texture mapping on models with shiny reaction < 1

Added by danij over 16 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
2005-01-20
% Done:

0%

Tags:

Description

There seems to be a problem with the wrapping of shiny
textures on models if you set shiny reaction to a value
< 1.
What happens for example on a HUD model:
As you turn everything seems fine the scrolling is
indeed slower but you get to a certain point and then
the texture "snaps back" to the start instead of
continuing to scroll.

Say for instance if the value is 0.5 then that would
suggest that the it would take two 360 degree rotations
before it gets back to 0. What I think is happening is
that it gets as far as 0.5 and then snaps back to 0
without ever going through 0.5 - 1.0

I don't know how easy this might be to fix but it is
very noticeable on HUD weapons.

Try it by editing the DED in the HUD chaingun from the
jDRP 1.1 Alpha to see for yourself (or I can send you a
PK3 if you need to see it).

Labels: Graphics


Related issues

Related to Feature #1625: Per-pixel surface shading (bump/specular/reflection etc. mapping)Progressed2013-10-22

History

#1 Updated by skyjake over 7 years ago

  • Tags set to Renderer, 3DModel
  • Status changed from New to Closed

Closing this as obsolete. All future effort should instead be put into shader-based shiny/reflection mapping.

Also available in: Atom PDF