Project

General

Profile

Feature #2016

"Portable app" package (app contained in a folder, with all user data included; e.g., for USB sticks)

Added by danij about 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Redesign
Target version:
-
Start date:
2014-10-21
% Done:

50%


Description

Many Windows users find installers inconvenient and in certain situations, they'd prefer a so-called "portable application" package, where all components are delivered in a Zip that can unpacked anywhere.

See: http://en.wikipedia.org/wiki/Portable_application


Related issues

Follows Feature #1887: Migrate project build system to CMake 3Closed2014-10-20

Follows Feature #1600: Drop SnowberryClosed2014-04-192014-04-19

History

#1 Updated by danij about 7 years ago

  • Follows Feature #1887: Migrate project build system to CMake 3 added

#2 Updated by danij about 7 years ago

#3 Updated by skyjake about 7 years ago

  • Tags set to Windows, Installer
  • Due date deleted (2014-10-21)

#4 Updated by danij about 7 years ago

  • Due date deleted (2014-10-21)

#5 Updated by skyjake about 7 years ago

unpacked anywhere

Once we switch to CMake, It is pretty trivial to use CPack to generate a Zip installer, so that part of the issue is easy to address.

I don't really like the term "portable" in this context, as it is really about the app being relocatable: all data is stored within the app folder structure in such a way that it can be run from a USB drive, moved to another location on the disk, or even moved to another computer without losing any information or breaking anything.

#6 Updated by danij about 7 years ago

Yeah the terminology applied here truly sucks. My guess is this is a user-derived term. I don't think there is a compelling reason to continue using it (except perhaps in the documentation).

Snowberry uses the term "homeless" to describe this set up (adopted from the UNIX home directory) and I think it makes a lot more sense to apply this here.

#7 Updated by skyjake about 7 years ago

  • Due date deleted (2014-10-21)

#8 Updated by skyjake about 7 years ago

  • Subject changed from "Portable app" package to "Portable app" package (app contained in a folder, with all user data included; e.g., for USB sticks)

#9 Updated by skyjake over 6 years ago

  • Due date deleted (2014-12-06)

#10 Updated by skyjake about 6 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 50

Starting with build 1928, Windows builds are provided as ZIP packages in addition to MSI. To make these truly self-contained, one just needs to set the userdir appropriately (perhaps using a batch file or something similar).

#11 Updated by skyjake almost 6 years ago

  • Status changed from In Progress to Progressed

#12 Updated by skyjake over 2 years ago

  • Status changed from Progressed to Closed

Also available in: Atom PDF