Project

General

Profile

Bug #1964

Problems with sprites with special chars [ / ] (Doom Arch Vile disappears; Hexen crash when Traductus dies)

Added by vermil over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Regression
Target version:
Start date:
2015-02-11
% Done:

100%


Description

Pretty much what the subject states; the Arch Vile disappears during resurrecting a bad guy, before appearing again after resurrection.

When it goes to resurrect, the Arch Vile enters VILE_HEAL1.

hex1.save (20.1 KB) hex1.save Traductus getting gibbed skyjake, 2015-02-23 09:20

Related issues

Related to Bug #2253: [Doom] Arch-vile sprite disappears when resurrecting a monsterNew2017-07-01

Associated revisions

Revision e0119736 (diff)
Added by skyjake over 7 years ago

Debug|World: Avoid crash when analyzing alpha of a missing sprite texture

IssueID #1964

Revision 04452f9d (diff)
Added by skyjake over 7 years ago

Debug|World: Avoid crash when analyzing alpha of a missing sprite texture

IssueID #1964

Revision 422aba10 (diff)
Added by danij over 7 years ago

Fixed|MaterialTextureLayer|Resources: MaterialTextureLayer::AnimationStage() should not decode texture URIs

IssueID #1964

History

#1 Updated by vermil over 7 years ago

  • Tags set to Multiplayer

#2 Updated by skyjake over 7 years ago

  • Tags changed from Multiplayer to Multiplayer, Doom2

#3 Updated by skyjake over 7 years ago

  • Tags changed from Multiplayer, Doom2 to Multiplayer, Doom

#4 Updated by sonicdoommario over 7 years ago

I want to add onto this report and say that it happens during single player too, not just multiplayer. I saw it happen while running around levels in TNT and Plutonia with the latest build.

#5 Updated by skyjake over 7 years ago

  • Tags changed from Multiplayer, Doom to Doom, Animation
  • Subject changed from [Doom] Multiplayer Arch Vile disappears during resurrection to [Doom] Arch Vile disappears during resurrection

#6 Updated by vermil over 7 years ago

The Arch Vile's resurrecting sprites uniquely use the special [,/ and ] characters. I believe Dday's support for these characters (in wad at least), has been broken.

As a test I altered the Arch Vile's resurrecting states to use the first few sprites of the Imp (i.e A,B and C) and the Arch Vile no longer disappeared when resurrecting.

#7 Updated by skyjake over 7 years ago

  • Subject changed from [Doom] Arch Vile disappears during resurrection to [Doom] Arch Vile disappears during resurrection (special chars [ / ])

#8 Updated by vermil over 7 years ago

HeXen also uses sprites with these special characters, for both the last gib death state and the ice death state, of the Cleric.

When one gib's Traductus (Cleric Boss), Dday currently segfaults when it reaches the mentioned last frame. I haven't tried to freeze him, but I assume the same crash will occur.

#9 Updated by skyjake over 7 years ago

  • Subject changed from [Doom] Arch Vile disappears during resurrection (special chars [ / ]) to Problems with sprites with special chars [ / ] (Doom Arch Vile disappears; Hexen crash when Traductus dies)
  • Category set to Regression
  • Status changed from New to In Progress
  • Assignee set to skyjake
  • Priority changed from Normal to High
  • Target version set to 49

#10 Updated by skyjake over 7 years ago

  • Tags changed from Doom, Animation to Doom, Animation, Sprites, Hexen

#11 Updated by skyjake over 7 years ago

#12 Updated by skyjake over 7 years ago

  • % Done changed from 0 to 20

#13 Updated by skyjake over 7 years ago

I managed to find where the crash is occurring with Traductus (savegame attached). The associated commit 04452f9dc9e avoids the crash in the release build, however does nothing to address why the sprites are not being found.

#14 Updated by skyjake over 7 years ago

I've discovered that the reason why the sprites are missing is that findTextureForAnimationStage() fails with a MissingManifestError for URIs "Sprites:CLER[0" and "Sprites:CLER\0". This is likely due to a missing decode/encode of percent encoded URIs (somewhere).

#15 Updated by skyjake over 7 years ago

danij wrote:

I'm guessing the problem lies in the sprite Texture generation in ResourceSystem. The name should be encoded when inserting these into the PathTree.

#16 Updated by skyjake over 7 years ago

  • Assignee changed from skyjake to danij
  • % Done changed from 20 to 50

#17 Updated by skyjake over 7 years ago

  • Target version changed from 49 to 1.15

#18 Updated by danij over 7 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 50 to 100

#19 Updated by skyjake almost 5 years ago

  • Related to Bug #2253: [Doom] Arch-vile sprite disappears when resurrecting a monster added

Also available in: Atom PDF