Project

General

Profile

Bug #1828

Tutorial doesn't claim mouse after clicking during launch

Added by vermil almost 6 years ago. Updated almost 3 years ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
Defect
Start date:
2014-06-19
% Done:

0%

Tags:

Description

The Tutorial doesn't claim the mouse when it runs; the game running claims the mouse.

This means, one can't actually start the tutorial; all one can do is close it with Esc.

History

#1 Updated by vermil almost 6 years ago

Er, when one launches straight into a game (i.e with a -game).

#2 Updated by vermil almost 6 years ago

My apologies for another post. It turns out that this may be more specific than I thought.

If one clicks the mouse during game startup, mouse control is given to the game instead of the tutorial.

#3 Updated by skyjake almost 6 years ago

  • Tags set to UI, Input
  • Subject changed from Tutorial doesn't claim mouse to Tutorial doesn't claim mouse after clicking during launch
  • Category set to Defect
  • Priority changed from Normal to Low

#4 Updated by skyjake almost 6 years ago

vermil wrote:

one can't actually start the tutorial; all one can do is close it with Esc.

In all dialogs, Space and Enter will trigger the default button. This should work in the tutorial, too, even though the mouse cursor remains captured. (That is, if it doesn't, there's a separate bug.)

#5 Updated by vermil almost 6 years ago

I wasn't aware of those shortcut's. Thanks for the information.

#6 Updated by skyjake almost 3 years ago

  • Target version set to Input and game controllers

Also available in: Atom PDF