Project

General

Profile

Feature #1766

Server-supplied (i.e., remote) resource files

Added by skyjake almost 6 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Enhancement
Target version:
Start date:
2014-04-18
% Done:

100%


Description

The server provides clients with required resources, if the clients lack local copies. This would include PWADs, addons, 3D models, definitions, and the like. The purpose is to make it easier for clients to experience the game as intended by the server admin.

In practice, the server's resource packs could be made visible on the clients via a remote FS2 folder.

Also see the proposal about this.


Related issues

Related to Feature #9: Use local server to run single-player gamesProgressed2014-04-18

Related to Feature #1761: FS2 resource packagesClosed2014-04-18

Related to Feature #1601: Package managementIn Progress2014-04-18

Related to Feature #1878: [MP] Hosted files/pwads etc need client download and auto load/unload files Closed2014-10-15

Related to Bug #1899: [Heretic] MP client imediately seg faults (wrong WADs)Rejected2014-11-18

Related to Bug #1934: Crash due to IWAD version mismatch in multiplayerClosed2014-12-30

Related to Feature #2185: Package repositoriesIn Progress2016-11-20

Associated revisions

Revision 5515b674 (diff)
Added by skyjake over 2 years ago

Client|FS|Multiplayer: Download missing packages from server before joining

ServerLink's joining procedure was expanded to include an async step
for downloading any packages that the client is missing.

IssueID #1766

History

#1 Updated by skyjake over 5 years ago

  • Subject changed from Server-supplied resource files to Server-supplied (i.e., remote) resource files

#2 Updated by skyjake over 5 years ago

  • Related to Feature #1878: [MP] Hosted files/pwads etc need client download and auto load/unload files added

#3 Updated by skyjake over 5 years ago

  • Description updated (diff)

#4 Updated by skyjake over 5 years ago

  • Related to Bug #1899: [Heretic] MP client imediately seg faults (wrong WADs) added

#5 Updated by skyjake about 5 years ago

  • Priority changed from High to Urgent

#6 Updated by danij almost 5 years ago

  • Priority changed from Urgent to High

#7 Updated by skyjake over 4 years ago

  • Related to Bug #1934: Crash due to IWAD version mismatch in multiplayer added

#8 Updated by skyjake about 4 years ago

  • Target version set to 2.1 (Late 2018)

#9 Updated by skyjake about 3 years ago

#10 Updated by skyjake over 2 years ago

  • % Done changed from 0 to 50

#11 Updated by skyjake over 2 years ago

  • Status changed from New to In Progress

#12 Updated by skyjake over 2 years ago

  • Status changed from In Progress to Resolved
  • Assignee set to skyjake
  • % Done changed from 50 to 100

#13 Updated by skyjake over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF