Project

General

Profile

Bug #175

Doom II | Level 6. Z_Free: freed a pointer without ZONEID

Added by tux0rz about 18 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2004-06-25
% Done:

100%


Description

I got the error:
Z_Free: freed a pointer without ZONEID
On level 6 of Doom 2: The Crusher.
When you go down the elevator shaft in the beginning,
you'll see a bunch of those crazy minotaur looking
demons. Press the crusher button to crush them. Run and
grab the Plasma Gun (Of course). Then, I used the Super
Shotgun to blast the pink demons in the acid. I then
ran across the acid into the Secret Area, grabbed the
health, and used the teleporter.
It teleported me right into the crusher while it was
lowered. I appeared directly on the demons corpse.
I went back into jDoom > Doom II Open GL mode. Tried it
again. The bug repeated.
I'm using both the 3D Model Pack, and the Alternative
Model pack.

This is the Outfile:

Level 6: The Crusher
Author: id Software

Picked up 4 shotgun shells.
You got the shotgun!
You got the shotgun!
Picked up a medikit.
Picked up a clip.
You got the shotgun!
Picked up 4 shotgun shells.
You got the shotgun!
You got the shotgun!
Picked up 4 shotgun shells.
You got the shotgun!
You got the plasma gun!
Picked up a stimpack.
You've found a secret area!
Picked up a stimpack.
Z_Free: freed a pointer without ZONEID

I attached the complete Doomsday.out file if you need
to see it all.

Labels: jDoom

History

#1 Updated by skyjake almost 18 years ago

Logged In: YES
user_id=717323

I was unable to reproduce this bug.

#2 Updated by tux0rz almost 18 years ago

Logged In: YES
user_id=1071254

Well then most likely it's a bug with different hardware.
P4 1.6ghz
GeForce 4 MX 64MB
Sound Blaster Audigy 2
384 MB of SDRAM
WinXP Pro
Only things that I can think of that might have caused it.
...and yes, it is a pile of shit computer :)
Now, what's odd, is that I tried to reproduce this bug in
Linux. I wasn't able to.

#3 Updated by tux0rz almost 18 years ago

Logged In: YES
user_id=1071254

err, Topologi Linux, that is.

Also available in: Atom PDF