Project

General

Profile

Bug #1729

Repeat loading of DEHACKED patches specified on the command line following a game change

Added by vermil over 8 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Defect
Start date:
2014-02-25
% Done:

100%


Description

Unloading a game, doesn't unload any external Dehacked patches loaded.


Related issues

Related to Feature #1586: Load/manage add-ons from the home screenClosed2014-12-04

Related to Feature #1601: Package managementIn Progress2014-04-18

History

#1 Updated by danij over 8 years ago

Thats not possible. When a game is unloaded the entire definition database is reset before then parsing only those definitions which should be present in Ring Zero.

Can you explain the problem you have observed and provide step by step instructions on how to reproduce it.

#2 Updated by danij over 8 years ago

  • Assignee set to vermil

#3 Updated by vermil over 8 years ago

I'm using this mod with Dday, that comes with an external Dehacked patch.
http://www.doomworld.com/idgames/index.php?file=levels/doom2/Ports/m-o/marspr9c.zip

1. I launch Doom2 with the pwad and deh, through Snowberry.
2. I then unload the game (console command or taskbar).

If I then try to load any game (even Heretic or HeXen) through Ring Zero, the mods Dehacked patch is still being applied, with a variety of negative results on each games mobjs (for instance a crash at the start of E1M1 in Heretic's case).

#4 Updated by danij over 8 years ago

It sounds like the game session file list is not being cleared upon unloading the game, leading to the DEHACKED patch being loaded again when the current game is changed. I'll investigate...

#5 Updated by danij over 8 years ago

  • Subject changed from 'unload' misses Dehacked patches to Repeat loading of DEHACKED patches specified on the command line following a game change
  • Assignee changed from vermil to danij
  • Priority changed from Normal to High
  • Target version set to 1.14

#6 Updated by danij over 8 years ago

  • Tags set to RingZero, Resources

#7 Updated by danij over 8 years ago

  • Tags changed from RingZero, Resources to RingZero, Resources, DeHackEd

#8 Updated by danij over 8 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 20

#9 Updated by danij over 8 years ago

  • % Done changed from 20 to 70

#10 Updated by skyjake about 8 years ago

  • Target version changed from 1.14 to 1.15

#11 Updated by vermil over 7 years ago

I would like to add that this issue also affects ded's.

One can easily see such, by loading a ded that references a non-existing mobj state (the alert is repeated every time one returns to Ring Zero or loads a game).

#12 Updated by danij over 7 years ago

  • Assignee changed from danij to Deng Team
  • Target version changed from 1.15 to 42

#13 Updated by danij over 7 years ago

To fix the underlying issue the Right Way, requires implementing a new mechanism for describing game sessions; including the ordered list of add-ons, values for what were previously the games' command line options, and the session ID for multiplayer.

While it would be straightforward to add a one-line check to only load add-ons specified on the command line, when changing game if -game is specified and valid - this wouldn't address the issue of repeat application of command line options intended for the game. As such, doing so would introduce unintuitive behavior.

Consequently, although incorrect and unexpected, the current behavior is good enough until such time as a proper mechanism for game session handling (and persistence thereof) is implemented.

#14 Updated by skyjake about 7 years ago

  • Priority changed from High to Normal

#15 Updated by skyjake about 7 years ago

  • Target version changed from 42 to 2.0 – Home UI & Packages

#16 Updated by skyjake about 7 years ago

  • Assignee deleted (Deng Team)

#17 Updated by skyjake about 6 years ago

  • Related to Feature #1586: Load/manage add-ons from the home screen added

#18 Updated by skyjake about 6 years ago

#19 Updated by skyjake about 6 years ago

  • Tags changed from RingZero, Resources, DeHackEd to RingZero, Resources, DeHackEd, Packages
  • Category set to Defect
  • Assignee set to skyjake

#20 Updated by skyjake over 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 70 to 100

Dehacked patches are now loaded via the package system, and the "-deh" option has been replaced. See 8310385f79ffa.

#21 Updated by skyjake over 5 years ago

  • Status changed from Resolved to Closed

#22 Updated by skyjake over 5 years ago

  • Tags changed from RingZero, Resources, DeHackEd, Packages to Resources, DeHackEd, Packages, Home

Also available in: Atom PDF