Project

General

Profile

Bug #151

Dynamic lights and thin one sided walls

Added by chrisdragon over 18 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
-
Target version:
Start date:
2003-10-21
% Done:

100%


Description

I took two screenshots of dynamic lights STILL leaking,
but not through 2 sided walls, but single sided walls.
Take a look at the screenshots:

http://www.furnation.com/chrisdragon/dyn1.jpg
http://www.furnation.com/chrisdragon/dyn2.jpg

Make a sample map with thinnish walls seen in the
screenshots along with a light source (torch, flaming
barrel, lost soul, etc). Doing this will reproduce
this glitch/render bug.

Labels: Graphics

History

#1 Updated by skyjake over 18 years ago

Logged In: YES
user_id=717323

That is what's supposed to happen. The dynlight code
doesn't clip the lights, just determines which sectors are
impossible to reach via any route. In your example
screenshots, the apparent leakage is due to the close
proximity of a corner, around which the light is able to
spread.

I don't consider this worth fixing at this time.

Also available in: Atom PDF