Project

General

Profile

Feature #1503

[Unix] Basic command line options (e.g., help, version)

Added by legluondunet over 12 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
User experience
Target version:
Start date:
2010-01-02
% Done:

100%

Tags:

Description

Hello,

when I launch doomsday in a terminal console, it doesn't give me his version number, help or commands exemple.
If I launch it wothout option, I obtain:
$ doomsday
loadGamePlugin: No game library was specified.
Z_Shutdown: Used 0 volumes, total 0 bytes.
Same message for doomsday --help or doomsday --version or doomsday -h

Could you please add this command? All the executable on Linux have this command.
Exemple: launch of doomday in a terminal, the user could obtain default informations like:
- version
- tape --h or help for list of options
exemple of command line

Thanks for your interest.

LGDN.

Labels: User Interface


Related issues

Related to Feature #1688: Command line options documented with AmethystNew2013-12-23

Associated revisions

Revision 4ce0669d (diff)
Added by skyjake over 8 years ago

Unix|Client|Server: Added command line options --version and --help

It is customary in Unix to have these.

IssueID #1503

History

#1 Updated by danij almost 10 years ago

This is a feature request not a bug report.

#2 Updated by skyjake over 8 years ago

  • Tags set to Unix, CommandLine
  • Subject changed from [Linux] Doomsday executable info to [Unix] Basic command line options (e.g., help, version)
  • Category set to User experience
  • Assignee set to skyjake
  • Priority changed from Normal to High
  • Target version set to 1.13

This is actually quite important because users sometimes rely on --help/-h and --version/-v to query basic usage info from the executable.

Also very easy to implement.

#3 Updated by skyjake over 8 years ago

  • Status changed from New to In Progress

#4 Updated by skyjake over 8 years ago

To do this the right way, all the command line options should be documented using Amethyst much like console commands and variables are. This would result in, say, opthelp.txt that could then be loaded into the help string database.

The brief descriptions of each option would then be printed by --help. It would be helpful if the options were grouped by domain.

#5 Updated by danij over 8 years ago

There seems to be a fair degree of feature overlap with the in-game help presented via the console. Maybe we can bind a subset of the console commands to a set of command line argument patterns and then reuse the existing system? The advantage of which is that the user can then query what is possible from the command line after launch.

#6 Updated by skyjake over 8 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF