Project

General

Profile

Feature #1458

Handling obsolete IWADs

Added by mochtroid-x over 12 years ago. Updated 6 months ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
2007-10-06
% Done:

0%

Tags:

Description

I have become aware that there are people playing Doomsday online with Doom versions <1.9. Because of this, those of us with up-to-date iwads cannot play online with these people. These iwads are probably pirated as Id sells the up-to-date versions of Doom.

Labels: Gameplay


Related issues

Related to Bug #645: Fatal error "R_InitSprites: No patches found" (unknown IWAD)Rejected2009-03-21

History

#1 Updated by danij over 12 years ago

- Milestone: Next Release --> Eventually

#2 Updated by yagisan over 11 years ago

Logged In: YES
user_id=1248824
Originator: NO

removing from self

#3 Updated by danij over 11 years ago

What are your thoughts on this skyjake? I can see plenty of advantages in requiring the latest IWADs but do we really want a user's first experience of running Doomsday to be a dialog saying "You must update..."?

#4 Updated by skyjake over 6 years ago

I think that there should be a proper warning dialog that informs the client that the server is using a different IWAD. Maybe we could even determine if the server has an older or newer IWAD.

I think we should look into allowing clients to connect with no regard to the IWAD, but in case there are some errors in the gameplay it must be the client who "suffers" from it; the server or other players must not be affected.

This is one thing to think about for Beta 7.

#5 Updated by skyjake over 6 years ago

  • Tags set to UI, Multiplayer
  • Subject changed from Prevent play with non-updated iwads. to Handling obsolete IWADs
  • Priority changed from Normal to Low

#6 Updated by skyjake 6 months ago

  • Status changed from New to Closed

Also available in: Atom PDF