Project

General

Profile

Feature #1313

Submodel rotation angles

Added by danij over 17 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2003-12-24
% Done:

0%

Tags:

Description

The XOR opperation that should be used to turn on/off
model flags on submodels doesn't appear to work
correctly on the following flags:

Spin
Alignyaw
Alignpitch

There may be more (I haven't tested them all).

This does present a problem when creating
powerups/items etc... For instance creating a model
that spins inside a sphere where you wouldn't want the
sphere to rotate.

Running latest snapshot with jDoom, ded ver 6.

Dani J


Related issues

Related to Feature #7: Next-gen renderer (codename "Gloom")Progressed2003-07-10

Related to Feature #1322: Setting submodel scale independentlyRejected2004-01-17

History

#1 Updated by skyjake over 17 years ago

Logged In: YES
user_id=717323

This is, unfortunately, by design. Since all objects have only one rotation
angle (well, yaw and pitch), the models have only one as well.
Consequently all submodels of a model use the same angles.

This should be changed, though. There is no valid reason for not
allowing per-submodel angles, even though it makes R_ProjectThing() a
bit more complicated.

#2 Updated by skyjake over 7 years ago

  • Tags set to 3DModel, Renderer
  • Subject changed from Submodel Rotation Angles to Submodel rotation angles

#3 Updated by skyjake over 4 years ago

  • Status changed from New to Rejected

Obsoleted by newer model file formats.

Also available in: Atom PDF