Project

General

Profile

Bug #131

Crash with Cheb's Blood Effects

Added by skyjake almost 19 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
-
Target version:
Start date:
2003-09-08
% Done:

100%


Description

Quote Simon D.:

When i chose the add-on for doomsday last version :
cheb's blood LONG, there is automatically a bug. you
shoot one huy and doomsday freezes. windows must
close the program with error message.

I saw that bug for every version of doom (1 to
final), in exemple (DOOM 1 shores of hell, first
level, first enemy). I tested that bug with a friend
and other PC config and it's the same pb.

BUT when we chose cheb's SHORT blood the game
continues normally.

Labels: Resources

History

#1 Updated by skyjake almost 19 years ago

(originally posted by anonymous SF.net user)

Logged In: YES
user_id=638442

The problem is in this ded code:

Model {
State = "BLOOD3";
Scale = 2.0;
Offset = 2;
Md2{
File = "decor/blood/tinyblood.md2";
Frame = "Zero";};
}

Copy Model {
State = "SMALLPOOL";
Md2{
Frame = "Frame 1";};
}

State {
ID = "BLOOD3";
Sprite = "BLUD";
Frame = 0;
Tics = 1;
Next state = "SMALLPOOL";
}

This effect create a small poll of blood after shot any enemy.
The code works correctly in Doomsday 1.7.11 and older.

#2 Updated by skyjake over 18 years ago

Logged In: YES
user_id=717323

The problem appears to be that Cheb is using a sprite
called POB2. This sprite does not exist in Doom 1. Hence
the crash.

I fixed this by allowing the use of undefined sprites. If
one is encountered, the object is quietly hidden. This
doesn't fix the blood effect but it fixes the crash.

In Doom 2, I don't see any problems with the effect.

Also available in: Atom PDF