Project

General

Profile

Feature #1147

Windows NT4?

Added by skyjake about 17 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2003-03-23
% Done:

100%


Description

Is it impossible to support Windows NT4 again (OpenGL)?

I succeeded in running up to Doomsday 1.7.2
(jDoom1.14.1) - but since then DX7+ is needed even to
start - :-(

Why shouldn't we be able to run jDoom in OpenGL mode in
WindowsNT anymore... (it worked nearly perfectly
before) - some special DX sound features? - DirectPlay?

Labels: OS Support

History

#1 Updated by danij almost 17 years ago

Out of date.

#2 Updated by skyjake almost 14 years ago

Logged In: YES
user_id=717323

The most important feature lacking in NT4 support:
DirectInput 3, or some other NT4-compatible way to get input
events. Current DI3 init is broken.

#3 Updated by yagisan over 13 years ago

Logged In: YES
user_id=1248824

This can be possible again if we find out why SDL Input
didn't work on Win32.

#4 Updated by yagisan over 13 years ago

Logged In: YES
user_id=1248824

Assigning to myself. NT4 support should be possible once we
move to common routines on all platforms. Will investigate
how to best achieve this, but I do not believe anyone plays
this still on NT4, so I'm lowering the priority.

#5 Updated by skyjake over 12 years ago

(originally posted by anonymous SF.net user)

Logged In: YES
user_id=740426

Thank you for taking my request into account.
btw: I do still play doom on different ports and yes I
do still use NT4 on most of my machines..., :-)

#6 Updated by yagisan over 10 years ago

Logged In: YES
user_id=1248824
Originator: NO

removing from self

Also available in: Atom PDF