Project

General

Profile

Bug #1134

[Hexen] Uncaught exception in Heresiarch's Seminary

Added by arus-2 almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
2013-09-20
% Done:

100%


Description

Since commit 4a17186db0e22a8a02494ea5d9c7ac492817254d ("Cleanup|World|Sector: Determine missing materials when classifying sector clusters") Hexen "crashes" on map "Heresiarch's Seminary" when player tries to enter the center of the seminary (temple/chapel/castle/whatever you call it). Reproducible quickly every time by:

warp 13
kill
then enter the building.

Tail of doomsday's output:

Hexen

Loading map "MAP27"...
World::loadMap > WadMapConverter: Recognized a Hexen format map.
Map: Pruned 383 vertexes (0 equivalents, 383 unused).
^ : Geometry bounds:[(2112, -6336)>(3328, 1728) size:(5440, 8064)]
^ : Line blockmap dimensions:(43, 64)
^ : BSP built: 1165 Nodes, 1166 Leafs, 5774 Segments and 684 Vertexes.
Tree balance is 19:15.
^ : BSP built in 0.18 seconds.
^ : Mobj blockmap dimensions:(43, 64)
^ : Polyobj blockmap dimensions:(43, 64)
^ : BSP leaf blockmap dimensions:(43, 64)
Current map elements:
2467 Vertexes
2180 Lines
9 Polyobjs
368 Sectors
1165 BSP Nodes
1166 BSP Leafs
Map::initNodePiles: Completed in 0 seconds.
P_PtcInitForMap: Completed in 0 seconds.
PO_InitForMap: Initializing polyobjects.
Map::initSkyFix: Completed in 0 seconds.
Precaching completed in 0.63 seconds.
Rend_RadioInitForMap: Completed in 0.004 seconds.
Map::initBias: Completed in 0 seconds.
Sector #91 is unclosed near (512, 548).
Sector #94 is unclosed near (256, 96).
Sector #273 is unclosed near (-1322, 256).
Sector #304 is unclosed near (-672, -5632).
Sector #305 is unclosed near (-736, -5632).

Map 13 (27): HERESIARCH'S SEMINARY

Map::initSkyFix: Completed in 0.001 seconds.
Loop: Uncaught exception during loop iteration:
[InvalidSectionIdError] (Line::Side::section) Invalid section id 1
^ : Application terminated due to exception:
^ : Uncaught exception during loop iteration:
^ : [InvalidSectionIdError] (Line::Side::section) Invalid section id 1
^ :
^ : Restoring original display mode due to shutdown.
^ > Canvas: Lost focus.

Labels: Hexen, Renderer

History

#1 Updated by skyjake almost 9 years ago

- labels: --> Hexen, Data
- Priority: 1 --> 8

#2 Updated by danij almost 9 years ago

- assigned_to: Daniel Swanson

#3 Updated by danij almost 9 years ago

Fixed for the next 1.12 candidate build.

See: [fa7d1f]

#4 Updated by danij almost 9 years ago

- status: open --> fixed

#5 Updated by skyjake almost 9 years ago

I'm seeing the same error in other maps, e.g., map 8.

#6 Updated by skyjake almost 9 years ago

- labels: Hexen, Data --> Hexen, Renderer
- summary: Hexen exits at map Heresiarch's Seminary --> [Hexen] Uncaught exception in Heresiarch's Seminary

Also available in: Atom PDF