Project

General

Profile

Bug #1110

Doomsday fails to compile on gentoo because of python error

Added by kurikai over 9 years ago. Updated over 9 years ago.

Status:
Rejected
Priority:
Lowest
Assignee:
-
Category:
-
Target version:
Start date:
2013-01-26
% Done:

0%


Description

Doomsday fails to compile on gentoo because gentoo now uses python3 as the default version of python.

Temp? Fix is located here on the gentoo bug list
https://bugs.gentoo.org/show_bug.cgi?id=452262

The patch replaces the word "python"(which links to python3) with "python2"(which links to python2.7)

maybe "python" needs to be replaced with "SCRIPT_PYTHON" ?
as when using "
"SCRIPT_PYTHON = /usr/bin/python2" in the config.pri file does not work

History

#1 Updated by skyjake over 9 years ago

- status: open --> wont-fix

#2 Updated by skyjake over 9 years ago

I think the only acceptable long-term solution is to port all of Doomsday's Python build scripts to Python 3, and have Python 3 officially as a dependency for building Doomsday from source.

(Snowberry will not be ported, though, as it deprecated.)

#3 Updated by hasufell over 9 years ago

We don't need to convert to python3 at all. The solution on that bug is wrong too.

Gentoo has technically no problems to deal with this situation, it's simply an ebuild bug and totally unrelated to upstream. Please close this.
I will fix it myself, but I don't like the state of 1.9.10 (crash on startup or game freeze), so I don't know if I will bump this version.

#4 Updated by skyjake over 9 years ago

the state of 1.9.10 (crash on startup or game freeze)

Please post a stack trace of any crash you encounter (i.e., run under gdb).

Also available in: Atom PDF