Project

General

Profile

Bug #1106

[Linux] Crashing at start with errors: "Failed to Lock"

Added by yoalieh2 over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
2012-12-29
% Done:

100%


Description

Hi, I'm creating a package of Doomsday for Chakra Linux.

I've already uploaded version 1.9.8. Version 1.9.9 didn't compile, but 1.9.10 did.

When I run 1.9.10, doomsday starts, the window is shown, but in the first progress circle it crashes, sometimes a window is shown with an error message, but sometimes the window just crashes. Any time the program crashes the progress in the circle is different.

I followed the log when running from a terminal, when the program is trying to find resources for each game I can see some errors like:

CallbackThread: Uncaught exception: (Lockable::lock) Failed to lock

or

Application terminated due to exception:
(Lockable::lock) Failed to lock

Every time I try, different progress in the game list is done, but it never goes beyond this.

Labels: Chakra Linux Thread Lock

History

#1 Updated by skyjake over 9 years ago

- assigned_to: Jaakko Keränen
- priority: 1 --> 7

#2 Updated by skyjake over 9 years ago

I can reproduce the error. I'll see what's going on.

#4 Updated by yoalieh2 over 9 years ago

Ok, testing tomorrow in my build. Happy new year!

#5 Updated by yoalieh2 over 9 years ago

Ok, testing tomorrow in my build. Happy new year!

#6 Updated by yoalieh2 over 9 years ago

Ok, testing tomorrow in my build. Happy new year!

#7 Updated by skyjake over 9 years ago

- status: open --> fixed

#8 Updated by skyjake about 9 years ago

(originally posted by anonymous SF.net user)

The same happens using the stable version in Ubuntu 12.10 installed with the .deb files.

Also available in: Atom PDF