Project

General

Profile

Bug #110

Feature #1648: Complete vanilla DOOM emulation

Feature #1603: Support for id Tech 1 map hacks

[Render hack] TNT map09: Transparent window is not transparent

Added by skyjake over 16 years ago. Updated 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Vanilla emulation
Target version:
Start date:
2003-07-17
% Done:

100%

Tags:

Description

Quote Stephen Howe:

1. Visit TNT level 09, Stronghold
2. Go to coords X = -1040, Y = 240
3. You should be in front of a window that shows some
Sergents behind. Now in the original Final Doom, this
window is transparent. In JDoom it is not.

Labels: Doom, Render hack


Related issues

Related to Bug #2399: [Render hack] TNT map21: Transparent doorsNew2020-01-12

Associated revisions

Revision 0ddc5c7e (diff)
Added by skyjake 2 months ago

Map Importer: Detect flat bleeding

IssueID #110

History

#1 Updated by skyjake over 16 years ago

Logged In: YES
user_id=717323

The problem is a trick that works in the original Doom.
The window is a zero-height sector with no textures
assigned to the surrounding lines.

#2 Updated by danij almost 14 years ago

Logged In: YES
user_id=849456

Note to self:
This issue is now "half" fixed.

The remaining glitch is a product of the same issue as with
bug #743780.

Once detection is rationalized, reintroduce missing texture
replacement in such a way that all wall seg related
rendering algorithms respond to any changes - without
changing the "offical" textures on the sidedef.

#4 Updated by yagisan over 13 years ago

Logged In: YES
user_id=1248824

Dani, this looks ok in 1.9.0beta4 (see attached screenshot).
Is this bug fixed ?

#5 Updated by danij over 13 years ago

Logged In: YES
user_id=849456

No not completely. This particular variation on this trick
is fixed but there is another similar trick that is setup
differently in the map geometry that I will be able to fix
using a method based on this. So, I left this open to remind
me :)

#6 Updated by yagisan over 13 years ago

Logged In: YES
user_id=1248824

Ok. I had some spare time to triage bugs, so I though I'd
double check it. I'll reassign it to the current release as
it is still affected (and it means I won't forget I checked it)

#7 Updated by yagisan over 12 years ago

Logged In: YES
user_id=1248824
Originator: NO

bump - whats happening here ?

#8 Updated by danij over 12 years ago

Logged In: YES
user_id=849456
Originator: NO

We are almost ready to begin supporting these tricks.

I've been in discussions with Ajapted (of glBSP) who has provided me with a document detailing how glBSP reacts to these tricks and what it will produce in GL Nodes. I've also constructed a map containing examples of every DOOM.exe renderer trick I have come across to use for development with some fairly detailed notes to accompany it (covering common variations and screenshots of what the trick looks like in DOOM.exe). I plan to add the information to the DEW when made legible :-)

The map load algorithms have been enhanced so that some of the advanced tricks will no longer prevent the map from being loaded in Doomsday.

I plan to work on support for these tricks post 1.9.0-beta6

#9 Updated by eunbolt almost 10 years ago

just a note to say as of deng 1.9beta-6.9 this bug still exists

#10 Updated by danij over 7 years ago

- labels: Graphics --> Doom, Render hack
- summary: [Doom] TNT map09: Transparent window --> [Render hack] TNT map09: Transparent window

#11 Updated by skyjake over 6 years ago

  • Category set to Vanilla emulation

#12 Updated by skyjake over 6 years ago

  • Parent task set to #1603

#13 Updated by skyjake over 6 years ago

  • Priority changed from High to Urgent

#14 Updated by skyjake almost 5 years ago

  • Priority changed from Urgent to High

#15 Updated by skyjake over 3 years ago

  • Target version deleted (1.9.0-beta6)

#16 Updated by skyjake almost 3 years ago

  • Target version set to Rendering

#17 Updated by skyjake almost 3 years ago

  • Target version changed from Rendering to Vanilla / Gameplay

#18 Updated by skyjake 2 months ago

  • Status changed from New to In Progress
  • Assignee set to skyjake
  • Target version changed from Vanilla / Gameplay to 2.3
  • % Done changed from 0 to 50

#19 Updated by skyjake 2 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

#20 Updated by skyjake 2 months ago

  • Subject changed from [Render hack] TNT map09: Transparent window to TNT map09: Transparent window is not transparent

#21 Updated by skyjake 2 months ago

  • Subject changed from TNT map09: Transparent window is not transparent to [Render hack] TNT map09: Transparent window is not transparent

#22 Updated by skyjake about 1 month ago

  • Related to Bug #2399: [Render hack] TNT map21: Transparent doors added

Also available in: Atom PDF