Project

General

Profile

Bug #1027

[Doom] PWAD no longer loads

Added by vermil about 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2012-04-14
% Done:

100%


Description

If one uses the Load console command to load the same map containing Pwad twice, Doomsday will hang on BSP building when it tries to load a map from that Pwad.

Apologies if the above isn't well written; I had some difficulty writting it.

Labels: Data

History

#1 Updated by vermil about 10 years ago

Currently, it allows it (as indicated in my bug report above).

#2 Updated by vermil about 10 years ago

Ok. I've just discovered that the issue isn't anything to with the load console command.

I just happened to be testing using a pwad that the latest build (469), won't load.

So this bug report has now become; 'the newest build won't load my pwad that old builds did'. I'll update the report title.

#3 Updated by danij about 10 years ago

Please be more specific, what actually happens? Have you got a doomsday.out we can look at? Perhaps attach your PWAD to this report so we can test it.

#4 Updated by vermil about 10 years ago

Ok, I've emailed you the pwad. It's WIP. so I would prefer not to upload it here.

#5 Updated by vermil about 10 years ago

It causes Dday to crash with an illegal operation message.

The outfile states this:

Building BSP using tunable split factor of 7...
Canvas: Lost focus.

#6 Updated by danij about 10 years ago

Fixed for build #472

You might want to re-think what you are doing with this map, its just about the worst case scenario for GL Doom port I can think of. Even freezing the map geometry the best I can manage is 15fps.

#7 Updated by vermil about 10 years ago

Good job on fixing it.

Dday 1.8.6 manages 23.6fps for me in the worst spots, 1.9.7 only manages 8.7fps (generally speaking Dday 1.8.6 manages 15-20fps more than 1.9.7 in near all areas of the map).

GZDoom runs it near flawlessly, only dropping what I imagine is a few fps (GZDoom lacks an FPS counter) when looking at the entire map. Though obviously, GZDoom isn't pushing the graphics of Dday.

I am imaging the new renderer will dramatically improve performance of such maps in Dday.

#8 Updated by vermil about 10 years ago

I might be overstepping what is possible here, but is it possible to make the load console command refuse to load a file, if it has already been loaded and not modified since the previous time it was loaded?

Also available in: Atom PDF