Project

General

Profile

Bug #1021

Number and time formatting depends from locale

Added by vvv1 about 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2012-04-11
% Done:

100%


Description

Menu is not displayed properly since the Qt merge. Please see the attached screenshots.

Labels: System


Related issues

Related to Bug #2216: qt locale settingClosed2017-03-16

History

#2 Updated by skyjake about 10 years ago

Cannot reproduce on Mac, Windows or Ubuntu.

Possibly related to report https://sourceforge.net/tracker/index.php?func=detail&aid=3516954&group_id=74815&atid=542099

Possibly caused by GL state mismanagement.

#3 Updated by vvv1 about 10 years ago

How to reproduce:

1. Set locale: export LANG=ru_RU.KOI8-R
2. rm -rf ~/.doomsday
3. Install doomsday build452.
4. Start it: doomsday -g doom2
5. Exit and uninstall build452.
6. Install doomsday build455 or newer.
7. Start it: doomsday -g doom2

Before starting build455 or newer configuration values look like this:
con-background-alpha 0.75
After starting build455 or newer they converted to:
con-background-alpha 0,
After removing ~/.doomsday and starting build455 or newer again they look like:
con-background-alpha 0,75

So, numeric values format in qt-based builds depends from locale. But it shouldn't.

#4 Updated by skyjake about 10 years ago

You're right, Doomsday should override the locale for number and time formatting. Could you see if this is still occurring? (after commit 7f9db5ec)

#5 Updated by vvv1 about 10 years ago

Nothing changed. The issue still occurs.

#7 Updated by skyjake about 10 years ago

OK, I'll investigate a bit more...

#8 Updated by skyjake about 10 years ago

Fixed. I assumed the problem was on Qt side, but the actual issue was that no one was forcing the en_US locale on libc any more. I assume SDL used to do it previously.

#9 Updated by skyjake about 10 years ago

Note that you have to delete the old (corrupted) game.cfg to restore the default/good console variable values.

#10 Updated by vvv1 about 10 years ago

Now it's fixed. Thanks!

#11 Updated by skyjake over 5 years ago

  • Related to Bug #2216: qt locale setting added

Also available in: Atom PDF