Project

General

Profile

Bug #1019

[Win32] No keyboard input at the menu start screen

Added by martyfender about 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
2012-04-10
% Done:

100%


Description

Windows XP SP3, Doomsday build 465. After I get to the start menu screen in Doom E1 M1, there is no keyboard input until I alt tab out of the game and back, only mouse input. In addition, no monsters show up until I start a new game a second time. Weird, I have never seen this behavior before in Doomsday. Addons: resource pack, texture pack and interface pack for Doom.

Labels: User Interface

History

#1 Updated by skyjake about 10 years ago

Does this occur every time you start the game? Can you attach your Options.rsp here from the front-end runtime folder?

#2 Updated by martyfender about 10 years ago

I reinstalled and confirmed that this behavior doesn't happen in builds 458 and 462.

#4 Updated by danij about 10 years ago

We need a copy of your options.rsp to proceed with testing this. Neither skyjake nor myself are experiencing this issue with a default config.

I seem to recall you were using some sort of joypad to keyboard utility? Have you tried disabling that?

#5 Updated by martyfender about 10 years ago

I am only using a basic Logitech ps2 keyboard and a Microsoft optical intellimouse, quite a few years old, with default Win XP SP3 drivers, no Logitech or Microsoft keyboard or mouse crapware. I had attached the options.rsp file on 4/10. Was it not good?

#6 Updated by martyfender about 10 years ago

I was working on a friend's computer the last couple of day's and I installed the same Doomsday build on his much newer system: HP a6223w duel core AMD and Windows Vista Home premium, and noted the same behavior, which disappeared when I install an earlier build. I even used revouninstaller to to clean it before a reinstall. ( I had copied my build over directly from my external USB drive where my Doomsday is installed: J:\Games\Doomsday I Used Revo because even after I deleted the directory and installed Doomsday with your installer, in the addons path I was seeing my addons path: J:\Games\Doomsday\Snowberry\addons instead of C:\Program Files\Doomsday\Snowberry\addons. This persisted even though I manually deleted those entries in the Snowberry interface. I tried again after working on the system a day latter, after reboots, of course, and I was able to delete my drive entries. Some how the entries were saved despite deleting the whole game folder. Is it possible that entries still existed in the registry or in memory? Usually Revo Uninstaller's more agressive modes does a pretty good job of cleaning up.

#7 Updated by martyfender about 10 years ago

same behavior in build 469, but not in the build earlier I stated before.Do I need to do a clean install?

#8 Updated by skyjake about 10 years ago

You don't need a clean install.

Danij has been able to reproduce this issue now. We're looking into it.

Also available in: Atom PDF